2
1
0

I hope this is not too simple of a question, but is there a simple command to download the whole set of "Spring 2015" tagged packages listed on https://deswiki.cosmology.illinois.edu/confluence/display/CMBT/Semi-annual+version+upgrade+for+EUPS+packages?src=contextnavchildmode ?

think the answer is similar to what I found under "Installing a Complete Pipeline" here:

https://deswiki.cosmology.illinois.edu/confluence/pages/viewpage.action?title=EUPS+User%27s+Guide&spaceKey=CMBT#EUPSUser%27sGuide-Installingacompletepipeline

… or, in other words, something like this:

$ eups distrib install FIRSTCUT -t FIRSTCUT-stable

For the "Spring 2015" set of EUPS packages, would the equivalent command be this?:

$ eups distrib install SPRING2015 -t SPRING2015-stable

Thanks!

PS:  Has the Spring 2015 set of packages also been tested on MacOSX?  Thanks!

 

    CommentAdd your comment...

    1 answer

    1.  
      2
      1
      0

      Yes, There is a meta-package "Spring 2015" in the works, that should be ready tomorrow. The list of "Spring 2015" meta-packages is listed here:

      (OUTDATED) Spring 2015 - Semi-annual version upgrade for EUPS packages

      And the complete instructions is here: EUPS Meta-packages list and Installation Instructions

      In the mean time, for example, you can install all of the external python-related packages (numpy,scipy,matplotlib, etc) by doing:

      eups distrib install pythonCore spring2015+0 --nolocks

      For the set of cfistio-related packages:

      eups distrib install cfitsioBundle spring2015+0 --nolocks

      For the all of astromatic codes used by DESDM:

      eups distrib install astromatic spring2015+0 --nolocks

      etc.

       

      CommentAdd your comment...