1
0
-1

Recently updated my machine to Ubuntu 14.04 and now a repo I have been working with for some time on this machine gives me this when I do a git pull:

fatal: unable to access 'https://kmchenry@opensource.ncsa.illinois.edu/stash/scm/pol/polyglot.git/': gnutls_handshake() failed: Handshake failed

    CommentAdd your comment...

    1 answer

    1.  
      4
      3
      2

      This is related to the following issue https://bugs.launchpad.net/ubuntu/+source/gnutls26/+bug/1111882. There is no simple solution right now. The best solution is to switch from using http to ssh for pulls. This process requires 3 steps.

      1. Add a key to https://opensource.ncsa.illinois.edu/stash/plugins/servlet/ssh/account/keys
      2. Upload the private key to the machine and place in ~/.ssh/id_rsa
      3. Change the url of the repository using git remote set-url origin ssh://git@opensource...

       

      1. Rob Kooper
        To get around this another way I have enabled http access to stash. You should not use this to login to the webpage or send your credentials to commit. However to get read-only access you can replace the https with http in the url (i.e. the url above would read: http://opensource.ncsa.illinois.edu/stash/scm/pol/polyglot.git/).
      CommentAdd your comment...