1
0
-1

Several people (e.g., Alex Drlica-WagnerHenning SchmitzMatias Carrasco Kind) have noticed that easyaccess is failing to load the cache when logging into DESSCI.

> easyaccess
Loading metadata into cache...


 Couldn't load metadata into cache (try later), no autocompletion for tables, columns or users this time
    CommentAdd your comment...

    1 answer

    1.  
      2
      1
      0

      This is (very likely) occurring due to a timeout error as DESSCI becomes larger and the metadata becomes more unwieldy. The long term solution is to pre-build the cache daily to avoid making each user do it on login (see this issue on github). However, short term you can circumvent this timeout by logging in with the "-nr" flag and using the "refresh_metadata_cache" command:

      > easyaccess -nr
      easyaccess  1.3.0. The DESDM Database shell. 
      * Type 'help' or '?' to list commands. *
      _________
      DESDB ~> refresh_metadata_cache
      Updated 10.79 hours ago
      
      Re-creating metadata table ...
             |    ☆         |  Press Ctrl-C to abort FGOTTENMETADATA table Created!
      Loading metadata into cache...

      Unfortunately, building the cache does take a while, but you should only need to do it once a day(?).

        CommentAdd your comment...