Build: #22 failed

Job: Default Job failed

Stages & jobs

  1. Default Stage

Job result summary

Completed
Duration
31 seconds
Agent
buildserver-2.os.ncsa.edu
Revisions
theme
ed2e8a2b10e17505bda024250f60c8296e26e089 ed2e8a2b10e17505bda024250f60c8296e26e089
GeoDashboard
6b2b0a7c8ed4040d4c5a646bc54445e8d4097668 6b2b0a7c8ed4040d4c5a646bc54445e8d4097668
Fixed in
#23 (Code changes detected)
Number of retries
1
No failed test found. A possible compilation error occurred.

Error summary

The build generated some errors. See the full build log for more details.

npm http 304 https://registry.npmjs.org/amdefine
npm WARN engine hoek@2.16.3: wanted: {"node":">=0.10.40"} (current: {"node":"v0.10.28","npm":"1.4.9"})
npm WARN engine boom@2.10.1: wanted: {"node":">=0.10.40"} (current: {"node":"v0.10.28","npm":"1.4.9"})
npm WARN engine cryptiles@2.0.5: wanted: {"node":">=0.10.40"} (current: {"node":"v0.10.28","npm":"1.4.9"})
npm http GET https://registry.npmjs.org/lodash
npm http 304 https://registry.npmjs.org/lodash
npm http GET https://registry.npmjs.org/phantomjs
npm http GET https://registry.npmjs.org/mocha-phantomjs
npm http GET https://registry.npmjs.org/async
npm http 304 https://registry.npmjs.org/mocha-phantomjs
npm http GET https://registry.npmjs.org/highlight.js
npm http GET https://registry.npmjs.org/marked
npm http 304 https://registry.npmjs.org/async
npm http 200 https://registry.npmjs.org/marked
npm http GET https://registry.npmjs.org/marked/-/marked-0.5.1.tgz
npm http 200 https://registry.npmjs.org/highlight.js
npm http GET https://registry.npmjs.org/highlight.js/-/highlight.js-9.13.1.tgz
npm http 200 https://registry.npmjs.org/marked/-/marked-0.5.1.tgz
npm http 200 https://registry.npmjs.org/highlight.js/-/highlight.js-9.13.1.tgz
npm http 304 https://registry.npmjs.org/phantomjs
npm http GET https://registry.npmjs.org/extract-zip
npm http GET https://registry.npmjs.org/fs-extra
npm http GET https://registry.npmjs.org/kew
npm http GET https://registry.npmjs.org/hasha
npm http GET https://registry.npmjs.org/progress
npm http GET https://registry.npmjs.org/request-progress
npm http GET https://registry.npmjs.org/which
npm http GET https://registry.npmjs.org/request
npm http 304 https://registry.npmjs.org/fs-extra
npm http 304 https://registry.npmjs.org/kew
npm http 304 https://registry.npmjs.org/extract-zip
npm http 304 https://registry.npmjs.org/hasha
npm http GET https://registry.npmjs.org/mocha
npm http 304 https://registry.npmjs.org/which
npm http 304 https://registry.npmjs.org/request
npm http 304 https://registry.npmjs.org/request-progress
npm http 304 https://registry.npmjs.org/progress
npm http 200 https://registry.npmjs.org/mocha
npm http GET https://registry.npmjs.org/isexe
npm http 304 https://registry.npmjs.org/isexe
npm http GET https://registry.npmjs.org/keypress
npm http 304 https://registry.npmjs.org/keypress
npm http GET https://registry.npmjs.org/rimraf
npm http 304 https://registry.npmjs.org/rimraf
npm WARN engine hawk@3.1.3: wanted: {"node":">=0.10.32"} (current: {"node":"v0.10.28","npm":"1.4.9"})
npm http GET https://registry.npmjs.org/glob
npm http 304 https://registry.npmjs.org/glob
npm http GET https://registry.npmjs.org/chalk
npm http GET https://registry.npmjs.org/pinkie-promise
npm http 304 https://registry.npmjs.org/chalk
npm http 304 https://registry.npmjs.org/pinkie-promise
npm http GET https://registry.npmjs.org/inherits
npm http GET https://registry.npmjs.org/minimatch
npm http 304 https://registry.npmjs.org/inherits
npm http 304 https://registry.npmjs.org/minimatch
npm http GET https://registry.npmjs.org/pinkie
npm http 304 https://registry.npmjs.org/pinkie
npm http GET https://registry.npmjs.org/escape-string-regexp
npm http GET https://registry.npmjs.org/has-ansi
npm http GET https://registry.npmjs.org/strip-ansi
npm http GET https://registry.npmjs.org/ansi-styles
npm http GET https://registry.npmjs.org/supports-color
npm http 304 https://registry.npmjs.org/supports-color
npm http 304 https://registry.npmjs.org/has-ansi
npm http 304 https://registry.npmjs.org/strip-ansi
npm http 304 https://registry.npmjs.org/ansi-styles
npm http 304 https://registry.npmjs.org/escape-string-regexp
npm http GET https://registry.npmjs.org/diff
npm http GET https://registry.npmjs.org/debug
npm http GET https://registry.npmjs.org/mkdirp
npm http GET https://registry.npmjs.org/jade
npm http GET https://registry.npmjs.org/growl
npm http 304 https://registry.npmjs.org/diff
npm http 304 https://registry.npmjs.org/debug
npm http 304 https://registry.npmjs.org/mkdirp
npm http 304 https://registry.npmjs.org/jade
npm WARN deprecated jade@0.26.3: Jade has been renamed to pug, please install the latest version of pug instead of jade
npm http 304 https://registry.npmjs.org/growl
npm http GET https://registry.npmjs.org/debug/-/debug-4.1.0.tgz
npm http 200 https://registry.npmjs.org/debug/-/debug-4.1.0.tgz
npm http GET https://registry.npmjs.org/ansi-regex
npm http 304 https://registry.npmjs.org/ansi-regex
npm WARN engine cryptiles@2.0.5: wanted: {"node":">=0.10.40"} (current: {"node":"v0.10.28","npm":"1.4.9"})
npm WARN engine hoek@2.16.3: wanted: {"node":">=0.10.40"} (current: {"node":"v0.10.28","npm":"1.4.9"})
npm WARN engine boom@2.10.1: wanted: {"node":">=0.10.40"} (current: {"node":"v0.10.28","npm":"1.4.9"})
npm http GET https://registry.npmjs.org/ms
npm http 200 https://registry.npmjs.org/ms
npm http GET https://registry.npmjs.org/graceful-fs
npm http 304 https://registry.npmjs.org/graceful-fs
npm WARN deprecated graceful-fs@2.0.3: please upgrade to graceful-fs 4 for compatibility with current and future versions of Node.js
npm http GET https://registry.npmjs.org/lru-cache
npm http GET https://registry.npmjs.org/sigmund
npm http 304 https://registry.npmjs.org/sigmund
npm http 304 https://registry.npmjs.org/lru-cache
npm WARN engine fs-extra@7.0.0: wanted: {"node":">=6 <7 || >=8"} (current: {"node":"v0.10.28","npm":"1.4.9"})
npm http GET https://registry.npmjs.org/jsonfile
npm http GET https://registry.npmjs.org/universalify
npm http 304 https://registry.npmjs.org/jsonfile
npm http 304 https://registry.npmjs.org/universalify
npm WARN engine universalify@0.1.2: wanted: {"node":">= 4.0.0"} (current: {"node":"v0.10.28","npm":"1.4.9"})
npm http 304 https://registry.npmjs.org/lru-cache
npm http 304 https://registry.npmjs.org/sigmund
npm http GET https://registry.npmjs.org/rc
npm http GET https://registry.npmjs.org/underscore.string/-/underscore.string-3.3.5.tgz
npm http GET https://registry.npmjs.org/semver
npm http 304 https://registry.npmjs.org/rc
npm http GET https://registry.npmjs.org/gaze
npm http GET https://registry.npmjs.org/tiny-lr
npm http GET https://registry.npmjs.org/js-beautify
npm http 200 https://registry.npmjs.org/underscore.string/-/underscore.string-3.3.5.tgz
npm http GET https://registry.npmjs.org/graceful-fs
npm http 304 https://registry.npmjs.org/gaze
npm http GET https://registry.npmjs.org/inherits
npm http 304 https://registry.npmjs.org/tiny-lr
npm http 200 https://registry.npmjs.org/semver
npm http 304 https://registry.npmjs.org/graceful-fs
npm http 304 https://registry.npmjs.org/inherits
npm WARN deprecated graceful-fs@1.2.3: please upgrade to graceful-fs 4 for compatibility with current and future versions of Node.js
npm http 200 https://registry.npmjs.org/js-beautify
npm http GET https://registry.npmjs.org/js-beautify/-/js-beautify-1.8.8.tgz
npm http 200 https://registry.npmjs.org/js-beautify/-/js-beautify-1.8.8.tgz
npm WARN deprecated minimatch@0.3.0: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue
npm http GET https://registry.npmjs.org/argparse
npm http GET https://registry.npmjs.org/esprima
npm http 304 https://registry.npmjs.org/argparse
npm http 304 https://registry.npmjs.org/esprima
npm http GET https://registry.npmjs.org/debug
npm http GET https://registry.npmjs.org/qs
npm http GET https://registry.npmjs.org/faye-websocket
npm http GET https://registry.npmjs.org/noptify
npm http 304 https://registry.npmjs.org/faye-websocket
npm http 304 https://registry.npmjs.org/debug
npm http 304 https://registry.npmjs.org/qs
npm http 304 https://registry.npmjs.org/noptify
npm http GET https://registry.npmjs.org/globule
npm http 304 https://registry.npmjs.org/globule
npm http GET https://registry.npmjs.org/underscore
npm http 304 https://registry.npmjs.org/underscore
npm http GET https://registry.npmjs.org/minimist
npm http GET https://registry.npmjs.org/strip-json-comments
npm http GET https://registry.npmjs.org/deep-extend
npm http 304 https://registry.npmjs.org/minimist
npm http 304 https://registry.npmjs.org/strip-json-comments
npm http 304 https://registry.npmjs.org/deep-extend
npm http GET https://registry.npmjs.org/ini
npm http 304 https://registry.npmjs.org/ini
npm http GET https://registry.npmjs.org/util-deprecate
npm http GET https://registry.npmjs.org/sprintf-js
npm http 304 https://registry.npmjs.org/util-deprecate
npm WARN engine deep-extend@0.6.0: wanted: {"node":">=4.0.0"} (current: {"node":"v0.10.28","npm":"1.4.9"})
npm http 304 https://registry.npmjs.org/sprintf-js
npm http GET https://registry.npmjs.org/config-chain
npm http GET https://registry.npmjs.org/editorconfig
npm http GET https://registry.npmjs.org/mkdirp
npm http 200 https://registry.npmjs.org/config-chain
npm http GET https://registry.npmjs.org/config-chain/-/config-chain-1.1.12.tgz
npm http 200 https://registry.npmjs.org/editorconfig
npm http 304 https://registry.npmjs.org/mkdirp
npm http GET https://registry.npmjs.org/editorconfig/-/editorconfig-0.15.2.tgz
npm http 200 https://registry.npmjs.org/config-chain/-/config-chain-1.1.12.tgz
npm http 200 https://registry.npmjs.org/editorconfig/-/editorconfig-0.15.2.tgz
npm http GET https://registry.npmjs.org/proto-list
npm http 304 https://registry.npmjs.org/proto-list
npm http GET https://registry.npmjs.org/types/semver
npm http GET https://registry.npmjs.org/commander
npm http 304 https://registry.npmjs.org/commander
npm http GET https://registry.npmjs.org/types/node
npm http GET https://registry.npmjs.org/osenv
npm http 405 https://registry.npmjs.org/types/semver
npm http 304 https://registry.npmjs.org/osenv
npm http 405 https://registry.npmjs.org/types/node
npm ERR! error rolling back Error: ENOTEMPTY, rmdir '/home/bamboo/bamboo-agent-home/xml-data/build-dir/GEOD-GLTG1-JOB1/theme/node_modules/grunt-jsbeautifier/node_modules'
npm ERR! error rolling back  grunt-jsbeautifier@0.2.13 { [Error: ENOTEMPTY, rmdir '/home/bamboo/bamboo-agent-home/xml-data/build-dir/GEOD-GLTG1-JOB1/theme/node_modules/grunt-jsbeautifier/node_modules']
npm ERR! error rolling back   errno: 53,
npm ERR! error rolling back   code: 'ENOTEMPTY',
npm ERR! error rolling back   path: '/home/bamboo/bamboo-agent-home/xml-data/build-dir/GEOD-GLTG1-JOB1/theme/node_modules/grunt-jsbeautifier/node_modules' }
npm ERR! Error: Method Not Allowed
npm ERR!     at errorResponse (/home/bamboo/node-v0.10.28/lib/node_modules/npm/lib/cache.js:753:14)
npm ERR!     at /home/bamboo/node-v0.10.28/lib/node_modules/npm/lib/cache.js:773:12
npm ERR!     at saved (/home/bamboo/node-v0.10.28/lib/node_modules/npm/node_modules/npm-registry-client/lib/get.js:148:7)
npm ERR!     at /home/bamboo/node-v0.10.28/lib/node_modules/npm/node_modules/graceful-fs/polyfills.js:133:7
npm ERR!     at Object.oncomplete (fs.js:107:15)
npm ERR! If you need help, you may report this *entire* log,
npm ERR! including the npm and node versions, at:
npm ERR!     <http://github.com/npm/npm/issues>

npm ERR! System Linux 4.4.0-137-generic
npm ERR! command "/home/bamboo/node-v0.10.28/bin/node" "/home/bamboo/node-v0.10.28/bin/npm" "install"
npm ERR! cwd /home/bamboo/bamboo-agent-home/xml-data/build-dir/GEOD-GLTG1-JOB1/theme
npm ERR! node -v v0.10.28
npm ERR! npm -v 1.4.9
npm ERR! code E405
npm http GET https://registry.npmjs.org/os-homedir
npm http 304 https://registry.npmjs.org/os-homedir
npm http GET https://registry.npmjs.org/os-tmpdir
npm http 304 https://registry.npmjs.org/os-tmpdir
npm ERR!
npm ERR! Additional logging details can be found in:
npm ERR!     /home/bamboo/bamboo-agent-home/xml-data/build-dir/GEOD-GLTG1-JOB1/theme/npm-debug.log
npm ERR! not ok code 0