Build: #46 was successful

Job: Default Job was successful

Stages & jobs

  1. Default Stage

Job result summary

Completed
Duration
46 seconds
Revision
d4df1eab06f3704048957fb5aae73e90a35866b0 d4df1eab06f3704048957fb5aae73e90a35866b0
Successful since
#43 ()

Error summary

The build generated some errors. See the full build log for more details.

npm http GET https://registry.npmjs.org/async
npm http GET https://registry.npmjs.org/mocha-phantomjs
npm http 304 https://registry.npmjs.org/async
npm http 304 https://registry.npmjs.org/phantomjs
npm http 304 https://registry.npmjs.org/mocha-phantomjs
npm http GET https://registry.npmjs.org/mocha
npm http GET https://registry.npmjs.org/which
npm http GET https://registry.npmjs.org/marked
npm http 304 https://registry.npmjs.org/which
npm http GET https://registry.npmjs.org/highlight.js
npm http GET https://registry.npmjs.org/commander/-/commander-5.1.0.tgz
npm http GET https://registry.npmjs.org/fs-extra/-/fs-extra-9.0.0.tgz
npm http 200 https://registry.npmjs.org/marked
npm http 200 https://registry.npmjs.org/commander/-/commander-5.1.0.tgz
npm http 200 https://registry.npmjs.org/fs-extra/-/fs-extra-9.0.0.tgz
npm http 200 https://registry.npmjs.org/highlight.js
npm http 200 https://registry.npmjs.org/mocha
npm http GET https://registry.npmjs.org/keypress
npm http 304 https://registry.npmjs.org/keypress
npm http GET https://registry.npmjs.org/rimraf
npm http 304 https://registry.npmjs.org/rimraf
npm WARN engine hawk@3.1.3: wanted: {"node":">=0.10.32"} (current: {"node":"v0.10.28","npm":"1.4.9"})
npm WARN engine marked@1.0.0: wanted: {"node":">= 8.16.2"} (current: {"node":"v0.10.28","npm":"1.4.9"})
npm WARN engine commander@5.1.0: wanted: {"node":">= 6"} (current: {"node":"v0.10.28","npm":"1.4.9"})
npm WARN engine fs-extra@9.0.0: wanted: {"node":">=10"} (current: {"node":"v0.10.28","npm":"1.4.9"})
npm http GET https://registry.npmjs.org/glob
npm http 304 https://registry.npmjs.org/glob
npm http GET https://registry.npmjs.org/chalk
npm http GET https://registry.npmjs.org/inherits
npm http GET https://registry.npmjs.org/minimatch
npm http 304 https://registry.npmjs.org/inherits
npm http 304 https://registry.npmjs.org/minimatch
npm WARN deprecated mkdirp@0.3.5: Legacy versions of mkdirp are no longer supported. Please update to mkdirp 1.x. (Note that the API surface has changed to use Promises in 1.x.)
npm http GET https://registry.npmjs.org/growl
npm http GET https://registry.npmjs.org/jade
npm http GET https://registry.npmjs.org/diff
npm http 304 https://registry.npmjs.org/growl
npm http 304 https://registry.npmjs.org/jade
npm WARN deprecated jade@0.26.3: Jade has been renamed to pug, please install the latest version of pug instead of jade
npm http 200 https://registry.npmjs.org/diff
npm http GET https://registry.npmjs.org/diff/-/diff-1.0.7.tgz
npm http GET https://registry.npmjs.org/at-least-node
npm http GET https://registry.npmjs.org/universalify
npm http 200 https://registry.npmjs.org/diff/-/diff-1.0.7.tgz
npm http GET https://registry.npmjs.org/graceful-fs
npm http GET https://registry.npmjs.org/jsonfile/-/jsonfile-6.0.1.tgz
npm http 304 https://registry.npmjs.org/graceful-fs
npm http 200 https://registry.npmjs.org/at-least-node
npm http 200 https://registry.npmjs.org/universalify
npm http GET https://registry.npmjs.org/universalify/-/universalify-1.0.0.tgz
npm http GET https://registry.npmjs.org/at-least-node/-/at-least-node-1.0.0.tgz
npm http 200 https://registry.npmjs.org/jsonfile/-/jsonfile-6.0.1.tgz
npm http GET https://registry.npmjs.org/lodash
npm http 200 https://registry.npmjs.org/at-least-node/-/at-least-node-1.0.0.tgz
npm http 200 https://registry.npmjs.org/universalify/-/universalify-1.0.0.tgz
npm http 304 https://registry.npmjs.org/lodash
npm WARN engine at-least-node@1.0.0: wanted: {"node":">= 4.0.0"} (current: {"node":"v0.10.28","npm":"1.4.9"})
npm WARN engine universalify@1.0.0: wanted: {"node":">= 10.0.0"} (current: {"node":"v0.10.28","npm":"1.4.9"})
npm http GET https://registry.npmjs.org/ms
npm WARN engine hoek@2.16.3: wanted: {"node":">=0.10.40"} (current: {"node":"v0.10.28","npm":"1.4.9"})
npm WARN engine boom@2.10.1: wanted: {"node":">=0.10.40"} (current: {"node":"v0.10.28","npm":"1.4.9"})
npm WARN engine cryptiles@2.0.5: wanted: {"node":">=0.10.40"} (current: {"node":"v0.10.28","npm":"1.4.9"})
npm http 200 https://registry.npmjs.org/ms
npm WARN deprecated graceful-fs@2.0.3: please upgrade to graceful-fs 4 for compatibility with current and future versions of Node.js
npm http GET https://registry.npmjs.org/lru-cache
npm http GET https://registry.npmjs.org/sigmund
npm http 304 https://registry.npmjs.org/lru-cache
npm http 304 https://registry.npmjs.org/sigmund
npm http GET https://registry.npmjs.org/mkdirp
npm http 304 https://registry.npmjs.org/mkdirp
npm WARN deprecated mkdirp@0.3.0: Legacy versions of mkdirp are no longer supported. Please update to mkdirp 1.x. (Note that the API surface has changed to use Promises in 1.x.)
npm http 200 https://registry.npmjs.org/chalk
npm http GET https://registry.npmjs.org/pinkie
npm http GET https://registry.npmjs.org/ansi-styles
npm http GET https://registry.npmjs.org/escape-string-regexp
npm http GET https://registry.npmjs.org/has-ansi
npm http GET https://registry.npmjs.org/strip-ansi
npm http GET https://registry.npmjs.org/supports-color
npm http 304 https://registry.npmjs.org/pinkie
npm http GET https://registry.npmjs.org/generate-function
npm http GET https://registry.npmjs.org/generate-object-property
npm http GET https://registry.npmjs.org/jsonpointer
npm http GET https://registry.npmjs.org/is-my-ip-valid
npm http GET https://registry.npmjs.org/xtend
npm http 304 https://registry.npmjs.org/ansi-styles
npm http 304 https://registry.npmjs.org/supports-color
npm http 304 https://registry.npmjs.org/escape-string-regexp
npm http 304 https://registry.npmjs.org/strip-ansi
npm http 304 https://registry.npmjs.org/has-ansi
npm http 304 https://registry.npmjs.org/generate-function
npm http 304 https://registry.npmjs.org/generate-object-property
npm http 304 https://registry.npmjs.org/jsonpointer
npm http 304 https://registry.npmjs.org/xtend
npm http 304 https://registry.npmjs.org/is-my-ip-valid
npm http GET https://registry.npmjs.org/ansi-regex
npm http GET https://registry.npmjs.org/is-property
npm http GET https://registry.npmjs.org/is-property
npm http 304 https://registry.npmjs.org/ansi-regex
npm http 304 https://registry.npmjs.org/is-property
npm http 304 https://registry.npmjs.org/is-property

/home/bamboo/bamboo-agent-home/xml-data/build-dir/GEOD-MAIN546-JOB1/node_modules/grunt-docco/node_modules/docco/node_modules/fs-extra/lib/index.js:5
  ...require('./fs'),
  ^

/home/bamboo/bamboo-agent-home/xml-data/build-dir/GEOD-MAIN546-JOB1/node_modules/grunt-docco/node_modules/docco/node_modules/fs-extra/lib/index.js:5
  ...require('./fs'),
  ^
Java HotSpot(TM) 64-Bit Server VM warning: ignoring option MaxPermSize=384M; support was removed in 8.0