Page tree
Skip to end of metadata
Go to start of metadata
  1. Create VM
  2. Install ArcGIS 10.4.1 Desktop Version advanced.
    1. During the installation process select Advanced (ArcInfo) Single Use product.
  3. Install Git for windows
    1. https://gitforwindows.org/
  4. Clone extractor and pyclowder repositories to ~/Repositories
  5. Add Python, and Scripts to Path (for root user)
    1. For ArcGIS 10.7 you can use C:\Python27\ArcGIS10.7\, and C:\Python27\ArcGIS10.7\Scripts\
  6. Pip is installed by ArcGIS, but should be updated
    1. `python -m pip install --upgrade pip`
  7. Install pika
    1. requests has already been installed, but is needed if it gets removed in a later version of ArcGIS
  8. Install Pyclowder
  9. Install extractor requirements 
    1. http://www.7-zip.org/download.html
    2. xmltodict
  10. Update environment variables for root user. Make sure that Python, python/scripts, and 7zip are available in the system path environment variable.
  11. Verify that extractor is running fine

  12. Download and Install NSSM

Additional References 


  • No labels