Skip to end of metadata
Go to start of metadata

Daffodil is licensed under the University of Illinois/NCSA Open Source License.

Daffodil requires Java 8 or newer and Scala 2.11.8 or newer.

Below are the libraries that Daffodil depends on and their licenses.

CategoryLicenseDependency
Apache Similar to Apache License but with the acknowledgment clause removed org.jdom.jdom2-2.0.6
ApacheThe Apache Software License, Version 2.0com.fasterxml.jackson.core.jackson-core-2.8.8
ApacheThe Apache Software License, Version 2.0com.fasterxml.woodstox.woodstox-core-5.0.3
Apache The Apache Software License, Version 2.0 commons-io.commons-io-2.5
Apache The Apache Software License, Version 2.0 org.fusesource.jansi.jansi-1.14
Apache The Apache Software License, Version 2.0 xerces.xercesImpl-2.10.0 
Apache The Apache Software License, Version 2.0 xml-apis.xml-apis-1.4.01 
Apache The Apache Software License, Version 2.0 xml-resolver.xml-resolver-1.2 
BSD BSD passera.passera-0.1 
BSD BSD 3-Clause org.scala-lang.scala-library-2.11.8 
BSD BSD 3-Clause org.scala-lang.scala-reflect-2.11.0 
BSD BSD 3-clause org.scala-lang.modules.scala-parser-combinators_2.11-1.0.4 
BSD BSD 3-clause org.scala-lang.modules.scala-xml_2.11-1.0.6 
BSD The BSD License jline.jline-2.12.1 
BSDThe BSD License org.codehaus.woodstox.stax2-api-3.1.4
ICU ICU License com.ibm.icu.icu4j-51.1 
MIT MIT License org.rogach.scallop_2.11-0.9.5 
  • No labels