Uploaded image for project: 'Daffodil'
  1. Daffodil
  2. DFDL-546

When a sequence element has no name, any test referencing the root element of the sequence is skipped

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: s10
    • Component/s: None
    • Labels:
      None

      Description

      So far I have only verified that this is an issue when you have the following setup:

      named root element -> sequence -> element with no name

      In a test, if you specify the named root element as your root, it seems that the test is skipped. I tried debug mode but I still don't see any output for the test, and it isn't included in the test totals from the TDML runner. I first noticed this during multifile schema testing, because I was providing the element with a dfdl:ref and had gotten it confused with the ref property, thinking I didn't need to provide a name. I have since fixed the tests that was experiencing this issue, but if you need me to I can create another one and push it up for you to take a look.

        Gliffy Diagrams

          Attachments

            Activity

              People

              Assignee:
              jchab Jessie Chab
              Reporter:
              jchab Jessie Chab
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Tasks