Uploaded image for project: 'GeoDashboard'
  1. GeoDashboard
  2. GEOD-1238

Markers Do Not Always Appear on the Download Page

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Done
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:

      Description

      This is a bug in the Geodashboard with the Search/Download page.

      The bug occurs if you try to load the page directly without going to another page first.
      Basically, the map does not display any of the markers in this situation.
      However, if you go to another page first (like the Explore Page) it does not occur.
      GLTG DEV has the bug currently if you want to test with a live example.

      For further details, it appears to be an OpenLayers related error.
      It is an Assertion Error (number 25): https://openlayers.org/en/v3.20.1/doc/errors/#25
      It is happening in the componentDidMount section of BasicMap (can see this when you go to the page after going to another page first)

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                Assignee:
                mpitcel2 Michelle Pitcel
                Reporter:
                mpitcel2 Michelle Pitcel
                Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                  Dates

                  Created:
                  Updated:
                  Resolved:

                    Time Tracking

                    Estimated:
                    Original Estimate - 2 days
                    2d
                    Remaining:
                    Remaining Estimate - 2 days
                    2d
                    Logged:
                    Time Spent - Not Specified
                    Not Specified

                      Tasks

                      Progress: 
                       0/0